CVE-2021-31998
Fixed in a distro release EPSS <1%CVSS 6.8
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
Products: SUSE Linux Enterprise Server 11-SP3, openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Point of Sale 11 SP3 | inn | 2.4.2-170.21.3.6.1 |
| SUSE Linux Enterprise Server 11 SP4-LTSS | inn | 2.4.2-170.21.3.6.1 |
| SUSE Package Hub 15 SP2 | inn | 2.6.2-bp152.2.8.1 |
| Ubuntu 16.04 LTS | inn2 | no fix |
| Ubuntu 18.04 LTS | inn2 | no fix |
| Ubuntu 20.04 LTS | inn2 | no fix |
| Ubuntu 22.04 LTS | inn2 | no fix |
| Ubuntu 24.04 LTS | inn2 | no fix |
| Ubuntu 25.10 | inn2 | no fix |
| Ubuntu 26.04 LTS | inn2 | no fix |
| Ubuntu 26.10 | inn2 | no fix |
| openSUSE Leap 15.2 | inn | 2.6.2-lp152.2.6.1 |