CVE-2021-27292
Fixed in a distro release EPSS 3%
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
Products: ua-parser-js_project ua-parser-js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | ua-parser-js | 0.7.24 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-ua-parser-js | 0.7.24+ds-1 |
| Debian 13 | node-ua-parser-js | 0.7.24+ds-1 |
| Debian 14 | node-ua-parser-js | 0.7.24+ds-1 |
| Ubuntu 18.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 20.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 22.04 LTS | node-ua-parser-js | no fix |