CVE-2021-25320
Fixed in a distro release EPSS <1%CVSS 9.9
A Improper Access Control vulnerability in Rancher, allows users in the cluster to make request to cloud providers by creating requests with the cloud-credential ID. Rancher in this case would attach the requested credentials without further checks This issue affects: Rancher versions prior to 2.5.9; Rancher versions prior to 2.4.16.
Products: Rancher
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/rancher/rancher | 2.4.16 |
| Go | github.com/rancher/rancher | 2.5.9 |
| Go | github.com/rancher/rancher | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | harvester | 0 |
| Chainguard | harvester-fips | 0 |
| Chainguard | harvester-fips-webhook | 0 |
| Chainguard | harvester-webhook | 0 |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260317T205859-150000.1.152.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |