CVE-2021-23727
Fixed in a distro release EPSS 4%CVSS 7.5
This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.
Products: celeryproject celery, fedoraproject extra_packages_for_enterprise_linux, fedoraproject fedora
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | celery | 5.2.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | celery | 5.2.3-1 |
| Debian 13 | celery | 5.2.3-1 |
| Debian 14 | celery | 5.2.3-1 |
| Ubuntu 14.04 LTS | celery | no fix |
| Ubuntu 16.04 LTS | celery | no fix |
| Ubuntu 18.04 LTS | celery | no fix |
| Ubuntu 20.04 LTS | celery | no fix |
| Ubuntu 24.04 LTS | celery | no fix |