CVE-2021-22051
Fixed upstream EPSS <1%
Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.
Products: vmware spring_cloud_gateway
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework.cloud:spring-cloud-gateway | 3.0.5 |
| Maven | org.springframework.cloud:spring-cloud-gateway | 2.2.10.RELEASE0.5 |