CVE-2020-7793
Fixed in a distro release EPSS 4%CVSS 7.5
The package ua-parser-js before 0.7.23 are vulnerable to Regular Expression Denial of Service (ReDoS) in multiple regexes (see linked commit for more info).
Products: ua-parser-js_project ua-parser-js, siemens sinec_ins
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | ua-parser-js | 0.7.23 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-ua-parser-js | 0.7.23+ds-1 |
| Debian 13 | node-ua-parser-js | 0.7.23+ds-1 |
| Debian 14 | node-ua-parser-js | 0.7.23+ds-1 |
| Ubuntu 18.04 LTS | node-ua-parser-js | no fix |
| Ubuntu 20.04 LTS | node-ua-parser-js | no fix |