CVE-2020-24972
Fixed in a distro release EPSS 5%CVSS 8.8
The Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.
Products: kleopatra_project kleopatra, fedoraproject fedora, opensuse backports_sle, opensuse leap
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | kleopatra | 4:20.08.2-2 |
| Debian 13 | kleopatra | 4:20.08.2-2 |
| Debian 14 | kleopatra | 4:20.08.2-2 |
| SUSE Package Hub 15 SP1 | kleopatra | 18.12.3-bp151.3.3.1 |
| Ubuntu 18.04 LTS | kleopatra | no fix |
| Ubuntu 20.04 LTS | kleopatra | no fix |
| Ubuntu 22.04 LTS | kleopatra | no fix |
| Ubuntu 24.04 LTS | kleopatra | no fix |
| Ubuntu 25.10 | kleopatra | no fix |
| Ubuntu 26.04 LTS | kleopatra | no fix |
| Ubuntu 26.10 | kleopatra | no fix |
| openSUSE Leap 15.1 | kleopatra | 18.12.3-lp151.2.4.1 |