CVE-2020-15138
Fixed in a distro release EPSS 2%CVSS 7.1
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
Products: PrismJS prism
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | prismjs | 1.21.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-prismjs | 1.11.0+dfsg-4 |
| Debian 13 | node-prismjs | 1.11.0+dfsg-4 |
| Debian 14 | node-prismjs | 1.11.0+dfsg-4 |
| Ubuntu 20.04 LTS | node-prismjs | no fix |