CVE-2020-15115
Fixed in a distro release EPSS 1%CVSS 5.8
etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
Products: etcd-io etcd
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | go.etcd.io/etcd/client/v3 | 3.4.10 |
| Go | go.etcd.io/etcd/client/v3 | 3.3.23 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian:12 | etcd | 3.3.25+dfsg-5 |
| Debian:13 | etcd | 3.3.25+dfsg-5 |
| Debian:14 | etcd | 3.3.25+dfsg-5 |
| Red Hat:openstack:16.1 | etcd | 0:3.3.23-1.el8ost |
| Red Hat:openstack:16.1 | etcd-debuginfo | 0:3.3.23-1.el8ost |
| Red Hat:openstack:16.1 | etcd-debugsource | 0:3.3.23-1.el8ost |
| Ubuntu:16.04:LTS | etcd | no fix |
| Ubuntu:25.10 | etcd | no fix |
| Ubuntu:26.10 | etcd | no fix |
| Ubuntu:Pro:18.04:LTS | etcd | no fix |
| Ubuntu:Pro:20.04:LTS | etcd | no fix |
| Ubuntu:Pro:22.04:LTS | etcd | no fix |
| Ubuntu:Pro:24.04:LTS | etcd | no fix |
| Ubuntu:Pro:26.04:LTS | etcd | no fix |