Patchwire CVEs, their patch status, and feeds to follow them

CVE-2020-11002

Fixed upstream EPSS 5%CVSS 8.0

dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.

Published 2020-04-10 · CVE record · OSV

Products: dropwizard

Fixed upstream

EcosystemPackageFixed in
Mavenio.dropwizard:dropwizard-validation1.3.21
Mavenio.dropwizard:dropwizard-validation2.0.3