CVE-2019-1798
Fixed in a distro release EPSS 1%CVSS 7.5
A vulnerability in the Portable Executable (PE) file scanning functionality of Clam AntiVirus (ClamAV) Software versions 0.101.1 and prior could allow an unauthenticated, remote attacker to cause a denial of service condition on an affected device. The vulnerability is due to a lack of proper input and validation checking mechanisms for PE files sent an affected device. An attacker could exploit this vulnerability by sending malformed PE files to the device running an affected version ClamAV Software. An exploit could allow the attacker to cause an out-of-bounds read condition, resulting in a crash that could result in a denial of service condition on an affected device.
Products: Cisco ClamAV
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | clamav | 0.101.2+dfsg-1 |
| Debian 12 | libclamunrar | 0.101.2-1 |
| Debian 13 | clamav | 0.101.2+dfsg-1 |
| Debian 13 | libclamunrar | 0.101.2-1 |
| Debian 14 | clamav | 0.101.2+dfsg-1 |
| Debian 14 | libclamunrar | 0.101.2-1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP1 | clamav | 0.103.0-3.23.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP2 | clamav | 0.103.0-3.23.1 |
| Ubuntu 14.04 LTS | clamav | 0.100.2+dfsg-1ubuntu0.14.04.2 |
| Ubuntu 14.04 LTS | libclamunrar | 0.100.1-1~ubuntu0.14.04.1 |
| Ubuntu 16.04 LTS | clamav | 0.100.2+dfsg-1ubuntu0.16.04.1 |
| Ubuntu 16.04 LTS | libclamunrar | 0.100.1-1~ubuntu0.16.04.1 |
| Ubuntu 18.04 LTS | clamav | 0.100.2+dfsg-1ubuntu0.18.04.1 |
| Ubuntu 18.04 LTS | libclamunrar | 0.100.1-1~ubuntu0.18.04.1 |
| openSUSE Leap 15.1 | clamav | 0.103.0-lp151.2.12.1 |
| openSUSE Leap 15.2 | clamav | 0.103.0-lp152.6.3.1 |
| openSUSE Tumbleweed | clamav | 0.103.3-1.4 |