CVE-2019-11291
Fixed in a distro release EPSS <1%CVSS 3.1
Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.
Products: Pivotal RabbitMQ, RabbitMQ for Pivotal Platform
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | rabbitmq-server | 3.8.3-1 |
| Debian 13 | rabbitmq-server | 3.8.3-1 |
| Debian 14 | rabbitmq-server | 3.8.3-1 |
| Red Hat openstack 15 | rabbitmq-server | 0:3.7.23-2.el8ost |
| Ubuntu 16.04 LTS | rabbitmq-server | 3.5.7-1ubuntu0.16.04.4 |
| Ubuntu 18.04 LTS | rabbitmq-server | 3.6.10-1ubuntu0.4 |
| Ubuntu 20.04 LTS | rabbitmq-server | 3.8.2-0ubuntu1.1 |