CVE-2019-11281
Fixed in a distro release EPSS 1%CVSS 2.4
Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would gain access to virtual hosts and policy management information.
Products: Pivotal RabbitMQ, Pivotal RabbitMq for PCF
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | rabbitmq-server | 3.7.18-1 |
| Debian 13 | rabbitmq-server | 3.7.18-1 |
| Debian 14 | rabbitmq-server | 3.7.18-1 |
| Debian 9 | rabbitmq-server | 3.6.6-1+deb9u1 |
| Red Hat openstack 15 | rabbitmq-server | 0:3.7.22-1.el8ost |
| Ubuntu 20.04 LTS | rabbitmq-server | 3.8.2-0ubuntu1 |