CVE-2019-10173
Fixed in a distro release EPSS 95%CVSS 7.3
It was found that xstream API version 1.4.10 before 1.4.11 introduced a regression for a previous deserialization flaw. If the security framework has not been initialized, it may allow a remote attacker to run arbitrary shell commands when unmarshalling XML or any supported format. e.g. JSON. (regression of CVE-2013-7285)
Products: xstream
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | com.thoughtworks.xstream:xstream | 1.4.11 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | hadoop-fips-3.3.6 | 3.3.6-r21 |
| Chainguard | hadoop-fips-3.4.2 | 3.4.2-r0 |
| Debian 12 | libxstream-java | 1.4.11-1 |
| Debian 13 | libxstream-java | 1.4.11-1 |
| Debian 14 | libxstream-java | 1.4.11-1 |