CVE-2018-25031
Fixed upstream EPSS 42%CVSS 4.3
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Products: smartbear swagger-ui
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.webjars:swagger-ui | 4.1.3 |
| npm | swagger-ui | 4.1.3 |