CVE-2018-1080
Fixed in a distro release EPSS 2%CVSS 7.5
Dogtag PKI, through version 10.6.1, has a vulnerability in AAclAuthz.java that, under certain configurations, causes the application of ACL allow and deny rules to be reversed. If a server is configured to process allow rules before deny rules (authz.evaluateOrder=allow,deny), then allow rules will deny access and deny rules will grant access. This may result in an escalation of privileges or have other unintended consequences.
Products: dogtagpki
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | dogtag-pki | 10.6.6-1 |
| Red Hat Enterprise Linux 7 | pki-base | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-base-java | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-ca | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-core | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-core-debuginfo | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-javadoc | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-kra | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-server | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-symkey | 0:10.5.1-13.1.el7_5 |
| Red Hat Enterprise Linux 7 | pki-tools | 0:10.5.1-13.1.el7_5 |
| Ubuntu Pro 16.04 LTS | dogtag-pki | no fix |