CVE-2018-1000873
Fixed upstream EPSS 5%
Fasterxml Jackson version Before 2.9.8 contains a CWE-20: Improper Input Validation vulnerability in Jackson-Modules-Java8 that can result in Causes a denial-of-service (DoS). This attack appear to be exploitable via The victim deserializes malicious input, specifically very large values in the nanoseconds field of a time value. This vulnerability appears to have been fixed in 2.9.8.
Products: fasterxml jackson-modules-java8, oracle clusterware, oracle database_server, oracle global_lifecycle_management_opatch, oracle nosql_database, netapp active_iq_unified_manager
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | com.fasterxml.jackson.datatype:jackson-datatype-jsr310 | 2.9.8 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu 18.04 LTS | jackson-databind | no fix |
| Ubuntu 20.04 LTS | jackson-databind | no fix |
| Ubuntu 22.04 LTS | jackson-databind | no fix |
| Ubuntu 24.04 LTS | jackson-databind | no fix |
| Ubuntu 25.10 | jackson-databind | no fix |
| Ubuntu 26.04 LTS | jackson-databind | no fix |
| Ubuntu 26.10 | jackson-databind | no fix |
| Ubuntu Pro 14.04 LTS | jackson-databind | no fix |
| Ubuntu Pro 16.04 LTS | jackson-databind | no fix |