CVE-2017-9022
Fixed in a distro release EPSS 2%CVSS 7.5
The gmp plugin in strongSwan before 5.5.3 does not properly validate RSA public keys before calling mpz_powm_sec, which allows remote peers to cause a denial of service (floating point exception and process crash) via a crafted certificate.
Products: strongswan, debian_linux, canonical ubuntu_linux
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.10 | strongswan | 5.5.3-r0 |
| Alpine 3.11 | strongswan | 5.5.3-r0 |
| Alpine 3.12 | strongswan | 5.5.3-r0 |
| Alpine 3.13 | strongswan | 5.5.3-r0 |
| Alpine 3.14 | strongswan | 5.5.3-r0 |
| Alpine 3.15 | strongswan | 5.5.3-r0 |
| Alpine 3.16 | strongswan | 5.5.3-r0 |
| Alpine 3.17 | strongswan | 5.5.3-r0 |
| Alpine 3.18 | strongswan | 5.5.3-r0 |
| Alpine 3.19 | strongswan | 5.5.3-r0 |
| Alpine 3.2 | strongswan | 5.3.5-r2 |
| Alpine 3.20 | strongswan | 5.5.3-r0 |
| Alpine 3.21 | strongswan | 5.5.3-r0 |
| Alpine 3.22 | strongswan | 5.5.3-r0 |
| Alpine 3.23 | strongswan | 5.5.3-r0 |
| Alpine 3.24 | strongswan | 5.5.3-r0 |
| Alpine 3.3 | strongswan | 5.3.5-r2 |
| Alpine 3.4 | strongswan | 5.4.0-r2 |
| Alpine 3.5 | strongswan | 5.5.3-r0 |
| Alpine 3.6 | strongswan | 5.5.3-r0 |
| Alpine 3.7 | strongswan | 5.5.3-r0 |
| Alpine 3.8 | strongswan | 5.5.3-r0 |
| Alpine 3.9 | strongswan | 5.5.3-r0 |
| Debian 12 | strongswan | 5.5.1-4 |
| Debian 13 | strongswan | 5.5.1-4 |
| Debian 14 | strongswan | 5.5.1-4 |
| Debian 7 | strongswan | 4.5.2-1.5+deb7u9 |
| Debian 8 | strongswan | 5.2.1-6+deb8u3 |
| SUSE Linux Enterprise Desktop 12 SP2 | strongswan | 5.1.3-25.1 |
| SUSE Linux Enterprise Server 11 SP4 | strongswan | 4.4.0-6.35.1 |
| SUSE Linux Enterprise Server 12 SP2 | strongswan | 5.1.3-25.1 |
| SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 | strongswan | 5.1.3-25.1 |
| SUSE Linux Enterprise Server for SAP Applications 11 SP4 | strongswan | 4.4.0-6.35.1 |
| SUSE Linux Enterprise Server for SAP Applications 12 SP2 | strongswan | 5.1.3-25.1 |
| Ubuntu 14.04 LTS | strongswan | 5.1.2-0ubuntu2.6 |
| Ubuntu 16.04 LTS | strongswan | 5.3.5-1ubuntu3.3 |
| openSUSE Tumbleweed | strongswan | 5.9.0-1.9 |