Patchwire CVEs, their patch status, and feeds to follow them

CVE-2017-2800

Fixed in a distro release EPSS 9%CVSS 8.1

A specially crafted x509 certificate can cause a single out of bounds byte overwrite in wolfSSL through 3.10.2 resulting in potential certificate validation vulnerabilities, denial of service and possible remote code execution. In order to trigger this vulnerability, the attacker needs to supply a malicious x509 certificate to either a server or a client application using this library.

Published 2017-05-24 · CVE record · OSV

Products: wolfssl

Distro releases

ReleasePackageFixed in
Debian 12wolfssl3.12.0+dfsg-1
Debian 13wolfssl3.12.0+dfsg-1
Ubuntu 16.04 LTSwolfsslno fix