CVE-2017-11185
Fixed in a distro release EPSS 3%CVSS 7.5
The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.
Products: strongswan
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.3 | strongswan | 5.3.5-r4 |
| Alpine 3.4 | strongswan | 5.4.0-r3 |
| Alpine 3.5 | strongswan | 5.5.3-r1 |
| Alpine 3.6 | strongswan | 5.5.3-r1 |
| Arch Linux | strongswan | 5.5.3-4 |
| Debian 12 | strongswan | 5.6.0-1 |
| Debian 13 | strongswan | 5.6.0-1 |
| Debian 14 | strongswan | 5.6.0-1 |
| Debian 7 | strongswan | 4.5.2-1.5+deb7u10 |
| Debian 8 | strongswan | 5.2.1-6+deb8u5 |
| Debian 9 | strongswan | 5.5.1-4+deb9u1 |
| SUSE Linux Enterprise Desktop 12 SP2 | strongswan | 5.1.3-26.5.1 |
| SUSE Linux Enterprise Desktop 12 SP3 | strongswan | 5.1.3-26.5.1 |
| SUSE Linux Enterprise Server 11 SP4 | strongswan | 4.4.0-6.36.3.1 |
| SUSE Linux Enterprise Server 12 SP2 | strongswan | 5.1.3-26.5.1 |
| SUSE Linux Enterprise Server 12 SP3 | strongswan | 5.1.3-26.5.1 |
| SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 | strongswan | 5.1.3-26.5.1 |
| SUSE Linux Enterprise Server for SAP Applications 11 SP4 | strongswan | 4.4.0-6.36.3.1 |
| SUSE Linux Enterprise Server for SAP Applications 12 SP2 | strongswan | 5.1.3-26.5.1 |
| SUSE Linux Enterprise Server for SAP Applications 12 SP3 | strongswan | 5.1.3-26.5.1 |
| Ubuntu 14.04 LTS | strongswan | 5.1.2-0ubuntu2.7 |
| Ubuntu 16.04 LTS | strongswan | 5.3.5-1ubuntu3.4 |
| openSUSE Tumbleweed | strongswan | 5.9.0-1.9 |