CVE-2016-5397
Fixed in a distro release EPSS 7%
The Apache Thrift Go client library exposed the potential during code generation for command injection due to using an external formatting tool. Affected Apache Thrift 0.9.3 and older, Fixed in Apache Thrift 0.10.0.
Products: Apache Software Foundation Apache Thrift
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/apache/thrift | 0.10.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | cadence | 1.4.0-r3 |
| Chainguard | cadence | 1.3.6-r0 |
| Chainguard | cadence-cassandra-tool | 1.4.0-r3 |
| Chainguard | cadence-fips | 1.4.0-r3 |
| Chainguard | cadence-fips | 1.3.6-r0 |
| Chainguard | cadence-fips-cassandra-tool | 1.4.0-r3 |
| Chainguard | cadence-fips-server | 1.4.0-r3 |
| Chainguard | cadence-fips-sql-tool | 1.4.0-r3 |
| Chainguard | cadence-server | 1.4.0-r3 |
| Chainguard | cadence-sql-tool | 1.4.0-r3 |
| Debian 12 | thrift | 0.11.0-3 |
| Debian 13 | thrift | 0.11.0-3 |
| Debian 14 | thrift | 0.11.0-3 |
| Ubuntu 16.04 LTS | thrift-compiler | no fix |
| Ubuntu 18.04 LTS | thrift-compiler | no fix |