Patchwire CVEs, their patch status, and feeds to follow them

CVE-2016-2120

Fixed in a distro release EPSS 2%CVSS 7.5

An issue has been found in PowerDNS Authoritative Server versions up to and including 3.4.10, 4.0.1 allowing an authorized user to crash the server by inserting a specially crafted record in a zone under their control then sending a DNS query for that record. The issue is due to an integer overflow when checking if the content of the record matches the expected size, allowing an attacker to cause a read past the buffer boundary.

Published 2018-11-01 · CVE record · OSV

Products: powerdns authoritative, debian_linux

Distro releases

ReleasePackageFixed in
Arch Linuxpowerdns4.0.2-1
Debian 12pdns4.0.2-1
Debian 13pdns4.0.2-1
Debian 14pdns4.0.2-1
Debian 7pdns3.1-4.1+deb7u3
Debian 8pdns3.4.1-4+deb8u7
Ubuntu Pro 16.04 LTSpdnsno fix
openSUSE Tumbleweedpdns4.5.1-1.5
openSUSE Tumbleweedpdns-recursor4.5.5-1.3