CVE-2015-7559
Fixed in a distro release EPSS 2%CVSS 2.7
It was found that the Apache ActiveMQ client before 5.14.5 exposed a remote shutdown command in the ActiveMQConnection class. An attacker logged into a compromised broker could use this flaw to achieve denial of service on a connected client.
Products: Apache ActiveMQ
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.activemq:activemq-client | 5.14.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | activemq | 5.14.3-3 |
| Debian 13 | activemq | 5.14.3-3 |
| Debian 7 | activemq | 5.6.0+dfsg-1+deb7u3 |
| Ubuntu 14.04 LTS | activemq | 5.6.0+dfsg-1+deb7u3build0.14.04.1 |
| Ubuntu Pro 16.04 LTS | activemq | 5.13.2+dfsg-2ubuntu0.1~esm1 |
| Ubuntu Pro 18.04 LTS | activemq | 5.15.8-2~18.04.1~esm1 |
| Ubuntu Pro 20.04 LTS | activemq | 5.15.11-1ubuntu0.1~esm1 |
| Ubuntu Pro 22.04 LTS | activemq | 5.16.1-1ubuntu0.1~esm1 |