CVE-2012-6711
Fixed in a distro release EPSS <1%CVSS 7.0
A heap-based buffer overflow exists in GNU Bash before 4.3 when wide characters, not supported by the current locale set in the LC_CTYPE environment variable, are printed through the echo built-in function. A local attacker, who can provide data to print through the "echo -e" built-in function, may use this flaw to crash a script or execute code with the privileges of the bash process. This occurs because ansicstr() in lib/sh/strtrans.c mishandles u32cconv().
Products: gnu bash, redhat enterprise_linux
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | bash | 4.3-1 |
| Debian 13 | bash | 4.3-1 |
| Debian 14 | bash | 4.3-1 |
| SUSE Linux Enterprise Server 12 SP1-LTSS | bash | 4.2-83.6.1 |
| SUSE Linux Enterprise Server for SAP Applications 12 SP1 | bash | 4.2-83.6.1 |